{"cve":"CVE-2020-2166","nvd":{"published":"2020-03-25T17:15:15.467","modified":"2026-06-17T03:11:54.493","status":"Modified","description":"Jenkins Pipeline: AWS Steps Plugin 1.40 and earlier does not configure its YAML parser to prevent the instantiation of arbitrary types, resulting in a remote code execution vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-20"],"references":["http://www.openwall.com/lists/oss-security/2020/03/25/2","https://jenkins.io/security/advisory/2020-03-25/#SECURITY-1741","http://www.openwall.com/lists/oss-security/2020/03/25/2","https://jenkins.io/security/advisory/2020-03-25/#SECURITY-1741"],"products":["jenkins:pipeline\\"],"source":"nvd","synced_at":"2026-10-19T21:03:08.679916934+00:00"},"epss":{"cve":"CVE-2020-2166","score":0.02034,"percentile":0.81075,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w598-25hm-jqx3","url":"https://osv.dev/vulnerability/GHSA-w598-25hm-jqx3","summary":"RCE vulnerability in Jenkins Pipeline: AWS Steps Plugin","modified":"2023-11-08T04:02:54.348863Z","packages":[{"ecosystem":"Maven","name":"de.taimos:pipeline-aws","purl":"pkg:maven/de.taimos/pipeline-aws","ranges":["<1.41"],"fixed":["1.41"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}