cve.bz

CVE-2020-14343

9.8 criticalEPSS 6.0%

Critical (9.8). EPSS 6.0% chance of exploitation in the next 30 days. Fixed in pyyaml 5.4.

A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
6.0% chance of exploitation in the next 30 days; higher than 93% of CVEs (scores of 2026-11-01)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8q59-q68h-6hv4PyPIpyyaml<5.45.4
PYSEC-2021-142PyPIpyyaml<5.45.4

References

Check your stackJSON