CVE-2019-10315
8.8 highEPSS 2.1%
High (8.8) in jenkins github authentication. EPSS 2.1% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:github-oauth 0.32.
Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.
Severity
CVSS 3.0
8.8 highCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H- EPSS
- 2.1% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
- CWE
- CWE-352
- Published
- Modified
- Record from
- the NVD, synced
Affected
- jenkins:github_authentication
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|
| GHSA-phwv-crgp-9r69 | Maven | org.jenkins-ci.plugins:github-oauth | <0.32 | 0.32 |
References
Check your stackJSON