{"cve":"CVE-2019-10315","nvd":{"published":"2019-04-30T13:29:05.813","modified":"2026-06-17T02:10:42.023","status":"Modified","description":"Jenkins GitHub Authentication Plugin 0.31 and earlier did not use the state parameter of OAuth to prevent CSRF.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["http://www.openwall.com/lists/oss-security/2019/04/30/5","http://www.securityfocus.com/bid/108159","https://jenkins.io/security/advisory/2019-04-30/#SECURITY-443","http://www.openwall.com/lists/oss-security/2019/04/30/5","http://www.securityfocus.com/bid/108159"],"products":["jenkins:github_authentication"],"source":"nvd","synced_at":"2026-10-19T20:56:19.218283075+00:00"},"epss":{"cve":"CVE-2019-10315","score":0.02143,"percentile":0.82071,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-phwv-crgp-9r69","url":"https://osv.dev/vulnerability/GHSA-phwv-crgp-9r69","summary":"Jenkins GitHub Authentication Plugin Cross-Site Request Forgery vulnerability","modified":"2024-02-16T08:02:03.731424Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:github-oauth","purl":"pkg:maven/org.jenkins-ci.plugins/github-oauth","ranges":["<0.32"],"fixed":["0.32"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}