cve.bz

CVE-2017-7481

9.8 criticalEPSS 4.8%

Critical (9.8). EPSS 4.8% chance of exploitation in the next 30 days. Fixed in ansible 2.1.6.0, 2.2.3.0, 2.3.1.0.

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
4.8% chance of exploitation in the next 30 days; higher than 91% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w578-j992-554xPyPIansible>=2.3.0.0 <2.3.1.02.3.1.0
GHSA-w578-j992-554xPyPIansible<2.1.6.02.1.6.0
GHSA-w578-j992-554xPyPIansible>=2.2.0.0 <2.2.3.02.2.3.0
PYSEC-2018-41PyPIansible<2.3.1.0
>=2.3.2.0 <2.4.0.0
2.3.1.0, 2.4.0.0

References

Check your stackJSON