{"cve":"CVE-2017-7481","nvd":{"published":"2018-07-19T13:29:00.340","modified":"2026-06-17T01:24:26.090","status":"Modified","description":"Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-20"],"references":["http://www.securityfocus.com/bid/98492","https://access.redhat.com/errata/RHSA-2017:1244","https://access.redhat.com/errata/RHSA-2017:1334","https://access.redhat.com/errata/RHSA-2017:1476","https://access.redhat.com/errata/RHSA-2017:1499"],"products":["canonical:ubuntu_linux","debian:debian_linux","redhat:ansible_engine","redhat:gluster_storage","redhat:openshift_container_platform","redhat:openstack","redhat:storage_console","redhat:virtualization","redhat:virtualization_manager"],"source":"nvd","synced_at":"2026-10-19T20:52:03.425131697+00:00"},"epss":{"cve":"CVE-2017-7481","score":0.04782,"percentile":0.91927,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w578-j992-554x","url":"https://osv.dev/vulnerability/GHSA-w578-j992-554x","summary":"Ansible fails to properly mark lookup-plugin results as unsafe","modified":"2025-05-29T22:55:27.692255Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.3.0.0 <2.3.1.0"],"fixed":["2.3.1.0"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.1.6.0"],"fixed":["2.1.6.0"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.2.0.0 <2.2.3.0"],"fixed":["2.2.3.0"]}]},{"id":"PYSEC-2018-41","url":"https://osv.dev/vulnerability/PYSEC-2018-41","summary":"","modified":"2023-11-08T03:59:24.627719Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.3.1.0",">=2.3.2.0 <2.4.0.0"],"fixed":["2.3.1.0","2.4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}