cve.bz

CVE-2017-16897

8.1 highEPSS 1.4%

High (8.1) in auth0 passport-wsfed-saml2. EPSS 1.4% chance of exploitation in the next 30 days. Fixed in passport-wsfed-saml2 3.0.5.

A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).

Severity

CVSS 3.0

8.1 high
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.4% chance of exploitation in the next 30 days; higher than 72% of CVEs (scores of 2026-10-31)
CWE
CWE-290
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-77fw-rf4v-vfp9npmpassport-wsfed-saml2<3.0.53.0.5

References

Check your stackJSON