{"cve":"CVE-2017-16897","nvd":{"published":"2017-12-27T17:08:17.483","modified":"2026-06-17T01:10:06.733","status":"Modified","description":"A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","score":8.1},"cwes":["CWE-290"],"references":["https://auth0.com/docs/security/bulletins/cve-2017-16897","https://auth0.com/docs/security/bulletins/cve-2017-16897"],"products":["auth0:passport-wsfed-saml2"],"source":"nvd","synced_at":"2026-10-19T20:47:56.471723566+00:00"},"epss":{"cve":"CVE-2017-16897","score":0.01378,"percentile":0.72098,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-77fw-rf4v-vfp9","url":"https://osv.dev/vulnerability/GHSA-77fw-rf4v-vfp9","summary":"passport-wsfed-saml2 vulnerable to Signature Bypass in SAML2 token","modified":"2023-11-08T03:59:13.976998Z","packages":[{"ecosystem":"npm","name":"passport-wsfed-saml2","purl":"pkg:npm/passport-wsfed-saml2","ranges":["<3.0.5"],"fixed":["3.0.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}