cve.bz

CVE-2017-16014

7.5 highEPSS 1.7%

High (7.5) in http-proxy project http-proxy. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in http-proxy 0.7.0.

Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 76% of CVEs (scores of 2026-10-31)
CWEs
CWE-388, CWE-703
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9xw9-pvgv-6p76npmhttp-proxy<0.7.00.7.0

References

Check your stackJSON