{"cve":"CVE-2017-16014","nvd":{"published":"2018-06-04T19:29:00.943","modified":"2026-06-17T01:08:38.587","status":"Modified","description":"Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-388","CWE-703"],"references":["https://github.com/nodejitsu/node-http-proxy/pull/101","https://nodesecurity.io/advisories/323","https://github.com/nodejitsu/node-http-proxy/pull/101","https://nodesecurity.io/advisories/323"],"products":["http-proxy_project:http-proxy"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2017-16014","score":0.0166,"percentile":0.76677,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9xw9-pvgv-6p76","url":"https://osv.dev/vulnerability/GHSA-9xw9-pvgv-6p76","summary":"Insufficient Error Handling in http-proxy","modified":"2023-11-08T03:58:59.708321Z","packages":[{"ecosystem":"npm","name":"http-proxy","purl":"pkg:npm/http-proxy","ranges":["<0.7.0"],"fixed":["0.7.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}