cve.bz

CVE-2017-12620

9.8 criticalEPSS 3.0%

Critical (9.8) in apache opennlp. EPSS 3.0% chance of exploitation in the next 30 days. Fixed in org.apache.opennlp:opennlp-tools 1.8.2.

When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.

Severity

CVSS 3.0

9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.0% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-611
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h22x-hm8g-rxpgMavenorg.apache.opennlp:opennlp-tools>=1.5.0 <1.8.21.8.2

References

Check your stackJSON