{"cve":"CVE-2017-12620","nvd":{"published":"2017-10-03T01:29:01.233","modified":"2026-06-17T01:03:38.823","status":"Modified","description":"When loading models or dictionaries that contain XML it is possible to perform an XXE attack, since Apache OpenNLP is a library, this only affects applications that load models or dictionaries from untrusted sources. The versions 1.5.0 to 1.5.3, 1.6.0, 1.7.0 to 1.7.2, 1.8.0 to 1.8.1 of Apache OpenNLP are affected.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-611"],"references":["http://opennlp.apache.org/news/cve-2017-12620.html","http://opennlp.apache.org/news/cve-2017-12620.html"],"products":["apache:opennlp"],"source":"nvd","synced_at":"2026-10-19T20:46:01.145313090+00:00"},"epss":{"cve":"CVE-2017-12620","score":0.03041,"percentile":0.87525,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-h22x-hm8g-rxpg","url":"https://osv.dev/vulnerability/GHSA-h22x-hm8g-rxpg","summary":"Improper Restriction of XML External Entity Reference in Apache OpenNLP","modified":"2023-11-08T03:58:53.308326Z","packages":[{"ecosystem":"Maven","name":"org.apache.opennlp:opennlp-tools","purl":"pkg:maven/org.apache.opennlp/opennlp-tools","ranges":[">=1.5.0 <1.8.2"],"fixed":["1.8.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}