cve.bz

CVE-2017-12612

7.8 highEPSS 0.7%

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

Severity

CVSS 3.0

7.8 high
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 54% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8rhc-48pp-52grMavenorg.apache.spark:spark-core_2.11<2.1.22.1.2
GHSA-8rhc-48pp-52grMavenorg.apache.spark:spark-core_2.10<2.1.22.1.2
GHSA-8rhc-48pp-52grPyPIpyspark<2.1.22.1.2
PYSEC-2017-147PyPIpyspark<2.1.22.1.2

References

Check your stackJSON