{"cve":"CVE-2017-12612","nvd":{"published":"2017-09-13T16:29:00.477","modified":"2026-06-17T01:03:37.253","status":"Modified","description":"In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-502"],"references":["http://www.securityfocus.com/bid/100823","https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E","http://www.securityfocus.com/bid/100823","https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E"],"products":["apache:spark"],"source":"nvd","synced_at":"2026-10-19T20:46:01.145313090+00:00"},"epss":{"cve":"CVE-2017-12612","score":0.00734,"percentile":0.54411,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8rhc-48pp-52gr","url":"https://osv.dev/vulnerability/GHSA-8rhc-48pp-52gr","summary":"Apache Spark Deserialization of Untrusted Data vulnerability","modified":"2024-11-26T19:07:38.712373Z","packages":[{"ecosystem":"Maven","name":"org.apache.spark:spark-core_2.11","purl":"pkg:maven/org.apache.spark/spark-core_2.11","ranges":["<2.1.2"],"fixed":["2.1.2"]},{"ecosystem":"Maven","name":"org.apache.spark:spark-core_2.10","purl":"pkg:maven/org.apache.spark/spark-core_2.10","ranges":["<2.1.2"],"fixed":["2.1.2"]},{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":["<2.1.2"],"fixed":["2.1.2"]}]},{"id":"PYSEC-2017-147","url":"https://osv.dev/vulnerability/PYSEC-2017-147","summary":"","modified":"2024-11-25T22:42:11.091237Z","packages":[{"ecosystem":"PyPI","name":"pyspark","purl":"pkg:pypi/pyspark","ranges":["<2.1.2"],"fixed":["2.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}