cve.bz

CVE-2017-0889

9.8 criticalEPSS 3.1%

Critical (9.8) in thoughtbot paperclip. EPSS 3.1% chance of exploitation in the next 30 days. Fixed in paperclip 5.2.0.

Paperclip ruby gem version 3.1.4 and later suffers from a Server-SIde Request Forgery (SSRF) vulnerability in the Paperclip::UriAdapter class. Attackers may be able to access information about internal network resources.

Severity

CVSS 3.0

9.8 critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.1% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
CWE
CWE-918
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5jcf-c5rg-rmm8RubyGemspaperclip>=3.1.4 <5.2.05.2.0

References

Check your stackJSON