cve.bz

CVE-2016-2537

7.5 highEPSS 1.8%

High (7.5) in is my json valid project is my json valid. EPSS 1.8% chance of exploitation in the next 30 days. Fixed in is-my-json-valid 2.12.4.

The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.

Severity

CVSS 3.0

7.5 high
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.8% chance of exploitation in the next 30 days; higher than 79% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f522-ffg8-j8r6npmis-my-json-valid<2.12.42.12.4

References

Check your stackJSON