{"cve":"CVE-2016-2537","nvd":{"published":"2016-02-23T05:59:01.217","modified":"2026-06-17T00:44:14.853","status":"Modified","description":"The is-my-json-valid package before 2.12.4 for Node.js has an incorrect exports['utc-millisec'] regular expression, which allows remote attackers to cause a denial of service (blocked event loop) via a crafted string.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-20"],"references":["https://github.com/mafintosh/is-my-json-valid/commit/eca4beb21e61877d76fdf6bea771f72f39544d9b","https://nodesecurity.io/advisories/76","https://github.com/mafintosh/is-my-json-valid/commit/eca4beb21e61877d76fdf6bea771f72f39544d9b","https://nodesecurity.io/advisories/76"],"products":["is_my_json_valid_project:is_my_json_valid"],"source":"nvd","synced_at":"2026-10-19T20:37:48.328043465+00:00"},"epss":{"cve":"CVE-2016-2537","score":0.01849,"percentile":0.79095,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-f522-ffg8-j8r6","url":"https://osv.dev/vulnerability/GHSA-f522-ffg8-j8r6","summary":"Regular Expression Denial of Service in is-my-json-valid","modified":"2025-10-17T17:50:27Z","packages":[{"ecosystem":"npm","name":"is-my-json-valid","purl":"pkg:npm/is-my-json-valid","ranges":["<2.12.4"],"fixed":["2.12.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}