cve.bz

CVE-2015-8856

6.1 mediumEPSS 2.5%

Medium (6.1) in openjsf serve-index. EPSS 2.5% chance of exploitation in the next 30 days. Fixed in serve-index 1.6.3.

Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
2.5% chance of exploitation in the next 30 days; higher than 84% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v633-x5vv-hqwcnpmserve-index<1.6.31.6.3

References

Check your stackJSON