{"cve":"CVE-2015-8856","nvd":{"published":"2017-01-23T21:59:00.563","modified":"2026-06-17T00:35:22.590","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2016/04/20/11","http://www.securityfocus.com/bid/96392","https://nodesecurity.io/advisories/34","http://www.openwall.com/lists/oss-security/2016/04/20/11","http://www.securityfocus.com/bid/96392"],"products":["openjsf:serve-index"],"source":"nvd","synced_at":"2026-10-19T20:41:25.729257544+00:00"},"epss":{"cve":"CVE-2015-8856","score":0.02477,"percentile":0.84564,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-v633-x5vv-hqwc","url":"https://osv.dev/vulnerability/GHSA-v633-x5vv-hqwc","summary":"Cross-Site Scripting in serve-index","modified":"2023-11-08T03:58:03.501904Z","packages":[{"ecosystem":"npm","name":"serve-index","purl":"pkg:npm/serve-index","ranges":["<1.6.3"],"fixed":["1.6.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}