CVE-2013-4287
No CVSS score yet. EPSS 3.3% chance of exploitation in the next 30 days. Fixed in rubygems-update 1.8.23.1, 1.8.26, 2.0.8.
Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.
- EPSS
- 3.3% chance of exploitation in the next 30 days; higher than 88% of CVEs (scores of 2026-10-31)
- CWE
- CWE-310
- Published
- Modified
- Record from
- the NVD, synced
Affected
- redhat:enterprise_linux
- ruby-lang:ruby
- rubygems:rubygems
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-9j7m-rjqx-48vh | RubyGems | rubygems-update | <1.8.23.1 | 1.8.23.1 |
| GHSA-9j7m-rjqx-48vh | RubyGems | rubygems-update | >=1.8.24 <1.8.26 | 1.8.26 |
| GHSA-9j7m-rjqx-48vh | RubyGems | rubygems-update | >=2.0.0 <2.0.8 | 2.0.8 |
| GHSA-9j7m-rjqx-48vh | RubyGems | rubygems-update | >=2.1.0.rc.1 <2.1.0 | 2.1.0 |