{"cve":"CVE-2013-4287","nvd":{"published":"2013-10-17T23:55:04.407","modified":"2026-06-16T23:56:57.593","status":"Modified","description":"Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-310"],"references":["http://blog.rubygems.org/2013/09/09/CVE-2013-4287.html","http://rhn.redhat.com/errata/RHSA-2013-1427.html","http://rhn.redhat.com/errata/RHSA-2013-1441.html","http://rhn.redhat.com/errata/RHSA-2013-1523.html","http://rhn.redhat.com/errata/RHSA-2013-1852.html"],"products":["redhat:enterprise_linux","ruby-lang:ruby","rubygems:rubygems"],"source":"nvd","synced_at":"2026-10-19T20:30:15.895642412+00:00"},"epss":{"cve":"CVE-2013-4287","score":0.03331,"percentile":0.88624,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9j7m-rjqx-48vh","url":"https://osv.dev/vulnerability/GHSA-9j7m-rjqx-48vh","summary":"RubyGems Regular Expression Denial of Service vulnerability","modified":"2024-11-29T05:42:20.333898Z","packages":[{"ecosystem":"RubyGems","name":"rubygems-update","purl":"pkg:gem/rubygems-update","ranges":["<1.8.23.1"],"fixed":["1.8.23.1"]},{"ecosystem":"RubyGems","name":"rubygems-update","purl":"pkg:gem/rubygems-update","ranges":[">=1.8.24 <1.8.26"],"fixed":["1.8.26"]},{"ecosystem":"RubyGems","name":"rubygems-update","purl":"pkg:gem/rubygems-update","ranges":[">=2.0.0 <2.0.8"],"fixed":["2.0.8"]},{"ecosystem":"RubyGems","name":"rubygems-update","purl":"pkg:gem/rubygems-update","ranges":[">=2.1.0.rc.1 <2.1.0"],"fixed":["2.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}