CVE-2012-6684
No CVSS score yet. EPSS 2.3% chance of exploitation in the next 30 days. Fixed in RedCloth 4.3.0.
Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.
- EPSS
- 2.3% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- debian:debian_linux
- redcloth:redcloth_library
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-r23g-3qw4-gfh2 | RubyGems | RedCloth | <4.3.0 | 4.3.0 |