{"cve":"CVE-2012-6684","nvd":{"published":"2015-01-08T01:59:01.267","modified":"2026-06-16T23:48:35.940","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://co3k.org/blog/redcloth-unfixed-xss-en","http://jgarber.lighthouseapp.com/projects/13054-redcloth/tickets/243-xss","http://seclists.org/fulldisclosure/2014/Dec/50","http://www.debian.org/security/2015/dsa-3168","https://gist.github.com/co3k/75b3cb416c342aa1414c"],"products":["debian:debian_linux","redcloth:redcloth_library"],"source":"nvd","synced_at":"2026-10-19T20:34:45.729216538+00:00"},"epss":{"cve":"CVE-2012-6684","score":0.02253,"percentile":0.82921,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r23g-3qw4-gfh2","url":"https://osv.dev/vulnerability/GHSA-r23g-3qw4-gfh2","summary":"RedCloth Cross-site Scripting vulnerability","modified":"2024-12-03T06:15:26.753053Z","packages":[{"ecosystem":"RubyGems","name":"RedCloth","purl":"pkg:gem/RedCloth","ranges":["<4.3.0"],"fixed":["4.3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}