Vulnerabilities (CVE)

Filtered by vendor Draytek Subscribe
Filtered by product Vigor2960 Firmware
Total 16 CVE
CVE Vendors Products Updated CVSS v2 CVSS v3
CVE-2023-24229 1 Draytek 2 Vigor2960, Vigor2960 Firmware 2023-03-19 N/A 7.8 HIGH
DrayTek Vigor2960 v1.5.1.4 was discovered to contain a command injection vulnerability via the mainfunction.cgi component.
CVE-2023-1009 1 Draytek 2 Vigor2960, Vigor2960 Firmware 2023-03-06 N/A 5.5 MEDIUM
A vulnerability classified as problematic has been found in DrayTek Vigor 2960 1.5.1.4. Affected is the function sub_1DF14 of the file /cgi-bin/mainfunction.cgi. The manipulation of the argument option with the input /../etc/password leads to path traversal. The attack needs to be done within the local network. The exploit has been disclosed to the public and may be used. VDB-221742 is the identifier assigned to this vulnerability.
CVE-2020-10826 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2022-04-22 10.0 HIGH 9.8 CRITICAL
/cgi-bin/activate.cgi on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve command injection via a remote HTTP request in DEBUG mode.
CVE-2021-43118 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2022-04-05 7.5 HIGH 9.8 CRITICAL
A Remote Command Injection vulnerability exists in DrayTek Vigor 2960 1.5.1.3, DrayTek Vigor 3900 1.5.1.3, and DrayTek Vigor 300B 1.5.1.3 via a crafted HTTP message containing malformed QUERY STRING in mainfunction.cgi, which could let a remote malicious user execute arbitrary code.
CVE-2021-42911 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2022-04-05 7.5 HIGH 9.8 CRITICAL
A Format String vulnerability exists in DrayTek Vigor 2960 <= 1.5.1.3, DrayTek Vigor 3900 <= 1.5.1.3, and DrayTek Vigor 300B <= 1.5.1.3 in the mainfunction.cgi file via a crafted HTTP message containing malformed QUERY STRING, which could let a remote malicious user execute arbitrary code.
CVE-2020-8515 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2022-01-01 10.0 HIGH 9.8 CRITICAL
DrayTek Vigor2960 1.3.1_Beta, Vigor3900 1.4.4_Beta, and Vigor300B 1.3.3_Beta, 1.4.2.1_Beta, and 1.4.4_Beta devices allow remote code execution as root (without authentication) via shell metacharacters to the cgi-bin/mainfunction.cgi URI. This issue has been fixed in Vigor3900/2960/300B v1.5.1.
CVE-2020-14472 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2021-12-21 7.5 HIGH 9.8 CRITICAL
On Draytek Vigor3900, Vigor2960, and Vigor 300B devices before 1.5.1.1, there are some command-injection vulnerabilities in the mainfunction.cgi file.
CVE-2020-19664 1 Draytek 2 Vigor2960, Vigor2960 Firmware 2021-07-21 6.5 MEDIUM 8.8 HIGH
DrayTek Vigor2960 1.5.1 allows remote command execution via shell metacharacters in a toLogin2FA action to mainfunction.cgi.
CVE-2020-15415 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-07-02 7.5 HIGH 9.8 CRITICAL
On DrayTek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1, cgi-bin/mainfunction.cgi/cvmcfgupload allows remote command execution via shell metacharacters in a filename when the text/x-python-script content type is used, a different issue than CVE-2020-14472.
CVE-2020-14473 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-30 7.5 HIGH 9.8 CRITICAL
Stack-based buffer overflow vulnerability in Vigor3900, Vigor2960, and Vigor300B with firmware before 1.5.1.1.
CVE-2020-14993 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-29 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow on DrayTek Vigor2960, Vigor3900, and Vigor300B devices before 1.5.1.1 allows remote attackers to execute arbitrary code via the formuserphonenumber parameter in an authusersms action to mainfunction.cgi.
CVE-2020-10823 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-23 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow in /cgi-bin/activate.cgi through var parameter on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request (issue 1 of 3).
CVE-2020-10828 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-23 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow in cvmd on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request.
CVE-2020-10827 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-23 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow in apmd on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request.
CVE-2020-10825 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-23 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow in /cgi-bin/activate.cgi while base64 decoding ticket parameter on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request (issue 3 of 3).
CVE-2020-10824 1 Draytek 6 Vigor2960, Vigor2960 Firmware, Vigor300b and 3 more 2020-06-23 7.5 HIGH 9.8 CRITICAL
A stack-based buffer overflow in /cgi-bin/activate.cgi through ticket parameter on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request (issue 2 of 3).