CWE-99: Improper Control of Resource Identifiers (Resource Injection), page 2
Filter
The product receives input from an upstream component, but it does not restrict or incorrectly restricts the input before it is used as an identifier for a resource that may be outside the intended control sphere.
What the weakness is: CWE-99 at MITRE. OWASP Top 10: A05:2025 Injection
Related attack patterns (CAPEC): 3
- CAPEC-10 Buffer Overflow via Environment Variables Likelihood: High · Severity: High
- CAPEC-75 Manipulating Writeable Configuration Files Likelihood: High · Severity: Very High
- CAPEC-240 Resource Injection Likelihood: High · Severity: High
The attack patterns MITRE's CAPEC relates to CWE-99, as MITRE names them. Credits.
Ask an AI about CWE-99
Show the prompt
Explain CWE-99: Improper Control of Resource Identifiers and how to prevent and detect it in code. Use https://cwe.mitre.org/data/definitions/99.html and https://cve.bz/cve/cwe/99?via=ask-ai-copy for recent CVEs with this weakness. Cite the sources.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this weakness's id and public links.
- 4.7CVE-2023-6601EPSS 0.4%
A flaw was found in FFmpeg's HLS demuxer. This vulnerability allows bypassing unsafe file extension checks and triggering arbitrary demuxers via base64-encoded data URIs appended with specific file extensions.
- 5.3CVE-2023-6602EPSS 0.5%
A flaw was found in FFmpeg's TTY Demuxer. This vulnerability allows possible data exfiltration via improper parsing of non-TTY-compliant input files in HLS playlists.
- 6.9CVE-2024-7658EPSS 0.8%
A vulnerability, which was classified as problematic, has been found in projectsend up to r1605. This issue affects the function get_preview of the file process.php. The manipulation leads to improper control of resource identifiers. The a…
- 5.3CVE-2024-7438EPSS 0.5%
A vulnerability has been found in SimpleMachines SMF 2.1.4 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file /index.php?action=profile;u=2;area=showalerts;do=read of the component User Al…
- 5.3CVE-2024-7437EPSS 0.4%
A vulnerability, which was classified as critical, was found in SimpleMachines SMF 2.1.4. Affected is an unknown function of the file /index.php?action=profile;u=2;area=showalerts;do=remove of the component Delete User Handler. The manipul…
- 2.7CVE-2024-0231EPSS 0.3%
A resource misdirection vulnerability in GitLab CE/EE versions 12.0 prior to 17.0.5, 17.1 prior to 17.1.3, and 17.2 prior to 17.2.1 allows an attacker to craft a repository import in such a way as to misdirect commits.
- 5.3CVE-2024-4817EPSS 0.9%
A vulnerability has been found in Campcodes Online Laundry Management System 1.0 and classified as critical. This vulnerability affects unknown code of the file manage_user.php of the component HTTP Request Parameter Handler. The manipulat…
- 8.8CVE-2024-4294EPSS 0.9%
A vulnerability, which was classified as critical, has been found in PHPGurukul Doctor Appointment Management System 1.0. Affected by this issue is some unknown functionality of the file /doctor/view-appointment-detail.php. The manipulatio…
- 8.8CVE-2023-3517EPSS 0.6%
Hitachi Vantara Pentaho Data Integration & Analytics versions before 9.5.0.1 and 9.3.0.5, including 8.3.x does not restrict JNDI identifiers during the creation of XActions, allowing control of system level data sources.
- 8.8CVE-2023-2980EPSS 1.1%
A vulnerability classified as critical was found in Abstrium Pydio Cells 4.2.0. This vulnerability affects unknown code of the component User Creation Handler. The manipulation leads to improper control of resource identifiers. The attack …
- 8.0CVE-2022-39369EPSS 2.4%
phpCAS is an authentication library that allows PHP applications to easily authenticate users via a Central Authentication Service (CAS) server. The phpCAS library uses HTTP headers to determine the service URL used to validate tickets. Th…
- 9.1CVE-2022-3774EPSS 1.5%
A vulnerability was found in SourceCodester Train Scheduler App 1.0 and classified as critical. Affected by this issue is some unknown functionality of the file /train_scheduler_app/?action=delete. The manipulation of the argument id leads…
- 6.5CVE-2022-27670EPSS 1.0%
SAP SQL Anywhere - version 17.0, allows an authenticated attacker to prevent legitimate users from accessing a SQL Anywhere database server by crashing the server with some queries that use indirect identifiers.
- 9.8CVE-2022-1287EPSS 0.7%
A vulnerability classified as critical was found in School Club Application System 1.0. This vulnerability affects a request to the file /scas/classes/Users.php?f=save_user. The manipulation with a POST request leads to privilege escalatio…
- 5.4CVE-2021-42360EPSS 0.6%
On sites that also had the Elementor plugin for WordPress installed, it was possible for users with the edit_posts capability, which includes Contributor-level users, to import blocks onto any page using the astra-page-elementor-batch-proc…
- 8.8CVE-2021-22879EPSS 5.0%
Nextcloud Desktop Client prior to 3.1.3 is vulnerable to resource injection by way of missing validation of URLs, allowing a malicious server to execute remote commands. User interaction is needed for exploitation.
- 7.8CVE-2020-8177EPSS 1.3%
curl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used.
- 6.7CVE-2020-6245EPSS 0.3%
SAP Business Objects Business Intelligence Platform, version 4.2, allows an attacker with access to local instance, to inject file or code that can be executed by the application due to Improper Control of Resource Identifiers.
- 7.5CVE-2020-5230EPSS 1.2%
Opencast before 8.1 and 7.6 allows almost arbitrary identifiers for media packages and elements to be used. This can be problematic for operation and security since such identifiers are sometimes used for file system operations which may l…
- 5.9CVE-2019-1860EPSS 1.3%
A vulnerability in the dashboard gadget rendering of Cisco Unified Intelligence Center could allow an unauthenticated, remote attacker to obtain or manipulate sensitive information between a user’s browser and Cisco Unified Intellige…
- 7.5CVE-2019-6545ExploitEPSS 14%
AVEVA Software, LLC InduSoft Web Studio prior to Version 8.1 SP3 and InTouch Edge HMI (formerly InTouch Machine Edition) prior to Version 2017 Update. An unauthenticated remote user could use a specially crafted database connection configu…
- 7.5CVE-2016-8615EPSS 4.7%
A flaw was found in curl before version 7.51. If cookie state is written into a cookie jar file that is later read back and used for subsequent requests, a malicious HTTP server can inject new cookies for arbitrary domains into said cookie…
- 9.8CVE-2017-5159EPSS 2.4%
An issue was discovered on Phoenix Contact mGuard devices that have been updated to Version 8.4.0. When updating an mGuard device to Version 8.4.0 via the update-upload facility, the update will succeed, but it will reset the password of t…