CWE-305: Authentication Bypass by Primary Weakness, page 4
Filter
The authentication algorithm is sound, but the implemented mechanism can be bypassed as the result of a separate weakness that is primary to the authentication error.
What the weakness is: CWE-305 at MITRE. OWASP Top 10: A07:2025 Authentication Failures
Ask an AI about CWE-305
Show the prompt
Explain CWE-305: Authentication Bypass by Primary Weakness and how to prevent and detect it in code. Use https://cwe.mitre.org/data/definitions/305.html and https://cve.bz/cve/cwe/305?via=ask-ai-copy for recent CVEs with this weakness. Cite the sources.Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this weakness's id and public links.
- 8.8CVE-2022-38700EPSS 0.4%
OpenHarmony-v3.1.1 and prior versions have a permission bypass vulnerability. LAN attackers can bypass permission control and get control of camera service.
- 5.5CVE-2022-38081EPSS 0.2%
OpenHarmony-v3.1.2 and prior versions have a permission bypass vulnerability. LAN attackers can bypass the distributed permission control.To take advantage of this weakness, attackers need another vulnerability to obtain system.
- 5.5CVE-2022-38064EPSS 0.2%
OpenHarmony-v3.1.2 and prior versions have a permission bypass vulnerability. Local attackers can bypass permission control and get sensitive information.
- 9.8CVE-2022-2651ExploitEPSS 16%
Authentication Bypass by Primary Weakness in GitHub repository bookwyrm-social/bookwyrm prior to 0.4.5.
- 7.7CVE-2021-45031EPSS 0.8%
A vulnerability in MEPSAN's USC+ before version 3.0 has a weakness in login function which lets attackers to generate high privileged accounts passwords.
- 9.8CVE-2022-0547EPSS 3.5%
OpenVPN 2.1 until v2.4.12 and v2.5.6 may enable authentication bypass in external authentication plug-ins when more than one of them makes use of deferred authentication replies, which allows an external user to be granted access with only…
- 7.8CVE-2022-23729EPSS 0.1%
When the device is in factory state, it can be access the shell without adb authentication process. The LG ID is LVE-SMP-210010.
- 6.5CVE-2022-0451EPSS 1.0%
Dart SDK contains the HTTPClient in dart:io library whcih includes authorization headers when handling cross origin redirects. These headers may be explicitly set and contain sensitive information. By default, HttpClient handles redirectio…
- 8.8CVE-2021-26726EPSS 1.1%
A remote code execution vulnerability affecting a Valmet DNA service listening on TCP port 1517, allows an attacker to execute commands with SYSTEM privileges This issue affects: Valmet DNA versions from Collection 2012 until Collection 20…
- 9.8CVE-2021-28503EPSS 0.7%
The impact of this vulnerability is that Arista's EOS eAPI may skip re-evaluating user credentials when certificate based authentication is used, which allows remote attackers to access the device via eAPI.
- 9.1CVE-2021-3850EPSS 2.2%
Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.
- 7.5CVE-2021-43175EPSS 1.2%
The GOautodial API prior to commit 3c3a979 made on October 13th, 2021 exposes an API router that accepts a username, password, and action that routes to other PHP files that implement the various API functions. Vulnerable versions of GOaut…
- 7.4CVE-2021-3547EPSS 1.2%
OpenVPN 3 Core Library version 3.6 and 3.6.1 allows a man-in-the-middle attacker to bypass the certificate authentication by issuing an unrelated server certificate using the same hostname found in the verify-x509-name option in a client c…
- 5.3CVE-2020-15077EPSS 1.2%
OpenVPN Access Server 2.8.7 and earlier versions allows a remote attackers to bypass authentication and access control channel data on servers configured with deferred authentication, which can be used to potentially trigger further inform…
- 7.5CVE-2020-15078EPSS 4.9%
OpenVPN 2.5.1 and earlier versions allows a remote attackers to bypass authentication and access control channel data on servers configured with deferred authentication, which can be used to potentially trigger further information leaks.
- 9.8CVE-2021-21403EPSS 1.4%
In github.com/kongchuanhujiao/server before version 1.3.21 there is an authentication Bypass by Primary Weakness vulnerability. All users are impacted. This is fixed in version 1.3.21.
- 7.3CVE-2020-14359EPSS 0.9%
A vulnerability was found in all versions of Keycloak Gatekeeper, where on using lower case HTTP headers (via cURL) an attacker can bypass our Gatekeeper. Lower case headers are also accepted by some webservers (e.g. Jetty). This means the…
- 9.8CVE-2020-24683EPSS 1.5%
The affected versions of S+ Operations (version 2.1 SP1 and earlier) used an approach for user authentication which relies on validation at the client node (client-side authentication). This is not as secure as having the server validate a…
- 9.8CVE-2020-15787EPSS 1.5%
A vulnerability has been identified in SIMATIC HMI Unified Comfort Panels (All versions <= V16). Affected devices insufficiently validate authentication attempts as the information given can be truncated to match only a set number of chara…
- 7.6CVE-2020-10126EPSS 0.3%
NCR SelfServ ATMs running APTRA XFS 05.01.00 do not properly validate softare updates for the bunch note acceptor (BNA), enabling an attacker with physical access to internal ATM components to restart the host computer and execute arbitrar…
- 5.3CVE-2020-10123EPSS 0.4%
The currency dispenser of NCR SelfSev ATMs running APTRA XFS 05.01.00 or earlier does not adequately authenticate session key generation requests from the host computer, allowing an attacker with physical access to internal ATM components …
- 8.8CVE-2020-10923ExploitEPSS 85%
This vulnerability allows network-adjacent attackers to bypass authentication on affected installations of NETGEAR R6700 V1.0.4.84_10.0.58 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists with…
- 7.5CVE-2020-11012EPSS 1.9%
MinIO versions before RELEASE.2020-04-23T00-58-49Z have an authentication bypass issue in the MinIO admin API. Given an admin access key, it is possible to perform admin API operations i.e. creating new service accounts for existing access…
- 9.8CVE-2019-14910EPSS 1.1%
A vulnerability was found in keycloak 7.x, when keycloak is configured with LDAP user federation and StartTLS is used instead of SSL/TLS from the LDAP server (ldaps), in this case user authentication succeeds even if invalid password has e…
- 8.3CVE-2019-14909EPSS 1.1%
A vulnerability was found in Keycloak 7.x where the user federation LDAP bind type is none (LDAP anonymous bind), any password, invalid or valid will be accepted.
- 5.4CVE-2019-14833EPSS 1.9%
A flaw was found in Samba, all versions starting samba 4.5.0 before samba 4.9.15, samba 4.10.10, samba 4.11.2, in the way it handles a user password change or a new password for a samba user. The Samba Active Directory Domain Controller ca…
- 4.2CVE-2019-0042EPSS 0.3%
Juniper Identity Management Service (JIMS) for Windows versions prior to 1.1.4 may send an incorrect message to associated SRX services gateways. This may allow an attacker with physical access to an existing domain connected Windows syste…
- 8.1CVE-2019-3878EPSS 3.0%
A vulnerability was found in mod_auth_mellon before v0.14.2. If Apache is configured as a reverse proxy and mod_auth_mellon is configured to only let through authenticated users (with the require valid-user directive), adding special HTTP …