cve.bz

CVE-2026-95860

9.1 criticalEPSS 0.6%

Critical (9.1). EPSS 0.6% estimated probability of exploitation activity in the next 30 days.

On this page
node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. SessionContext.getApplicableRolePermissions reads a missing or null DefaultRolePermissions metadata value instead of the configured namespace field, and the null result is treated permissively. An anonymous network client can consequently write variables with CurrentWrite access or call bound methods when an operator configured a restrictive namespace default and relied on inheritance. Servers with no declared policy, nodes with explicit per-node permissions, and correctly bound programmatic namespace metadata are outside the authorization-bypass case. This issue is fixed in version 2.180.0.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
0.6% estimated probability of exploitation activity in the next 30 days; 49th percentile. Scored 2026-11-04. A forecast for this CVE across the internet, not for your own systems.
CWEs
CWE-285 Improper Authorization
CWE-636 Not Failing Securely (Failing Open)
CWE-863 Incorrect Authorization
CWE-1188 Initialization of a Resource with an Insecure Default
OWASP Top 10
A01:2025 Broken Access Control, A10:2025 Mishandling of Exceptional Conditions
Published
Modified
Record from
the NVD, synced

Ask an AI about this CVE

Show the promptExplain CVE-2026-95860 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-95860?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-95860?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-95860 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.

Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.

Versions

From the CNA's record in the CVE List.

ProductAffected
node-opcua>= 2.42.0, < 2.180.0

Attack patterns (CAPEC)

  • CAPEC-665 Exploitation of Thunderbolt Protection Flaws Likelihood: Low · Severity: Very High

The attack patterns MITRE's CAPEC relates to this record's weaknesses, as MITRE names them. Credits. More on the page of CWE-285 (16).

References

Check your stackJSON