Critical (10.0). EPSS 0.8% chance of exploitation in the next 30 days. Fixed in vm2 3.11.7.
vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.