cve.bz

CVE-2026-77405

9.4 criticalEPSS 0.3%

Critical (9.4). EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/rabbitmq/amqp091-go 1.13.0.

RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.

Severity

CVSS 4.0

9.4 critical
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:H/SI:L/SA:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 20% of CVEs (scores of 2026-10-31)
CWE
CWE-326
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-33mj-cw25-m34hGogithub.com/rabbitmq/amqp091-go<1.13.01.13.0
GO-2026-6492Gogithub.com/rabbitmq/amqp091-go<1.13.01.13.0

References

Check your stackJSON