CVE-2026-75913
CodeWhale (codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in 0.8.64 by adding rev validation.
- CVSS 4.0
- 8.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H - CVSS 3.1
- 9.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:H - EPSS
- 0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-25)
- CWE
- CWE-73
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-7j5w-7r7x-9v27 | crates.io | deepseek-tui | >=0.3.27 <=0.8.41 | no fix published |
| GHSA-7j5w-7r7x-9v27 | npm | deepseek-tui | >=0.3.27 <0.8.41 | 0.8.41 |
| GHSA-7j5w-7r7x-9v27 | crates.io | codewhale-tui | >=0.8.41 <0.8.64 | 0.8.64 |
| GHSA-7j5w-7r7x-9v27 | npm | codewhale | >=0.8.41 <0.8.64 | 0.8.64 |