CVE-2026-7541
A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause service disruption by sending crafted requests with deeply nested JSON payloads to an unauthenticated API endpoint. The endpoint parsed user-controlled JSON request bodies without size or depth limits, causing excessive CPU and memory consumption. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.2, 3.19.6, 3.18.9, 3.17.15, and 3.16.18. This vulnerability was reported via the GitHub Bug Bounty program.
- CVSS 4.0
- 6.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H/E:U - CVSS 3.1
- 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - EPSS
- 0.4% chance of exploitation in the next 30 days; higher than 32% of CVEs (scores of 2026-10-26)
- CWE
- CWE-770
- Published
- Modified
- Record from
- the NVD, synced
Affected
- github:enterprise_server
References
- https://docs.github.com/en/enterprise-server@3.16/admin/release-notes#3.16.18
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.15
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.9
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.6
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.2