High (8.7) in jahlives openssl encrypt. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in openssl-encrypt 1.4.0.
openssl_encrypt versions before 1.4.0 contain a path traversal vulnerability in the _is_safe_path method where the plugin_id parameter is not sanitized before constructing the plugin config directory path. Attackers can declare a malicious plugin_id containing path traversal sequences like '../' to access arbitrary directories outside the intended plugin directory.