CVE-2026-7474
HashiCorp Nomad and Nomad Enterprise prior to 2.0.1 are vulnerable to code execution on the client host through a path traversal attack. This vulnerability (CVE-2026-7474) is fixed in Nomad 2.0.1, 1.11.5 and 1.10.11.
- CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 8.2% chance of exploitation in the next 30 days; higher than 94% of CVEs (scores of 2026-10-25)
- CWE
- CWE-22
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-hx53-77qj-8663 | Go | github.com/hashicorp/nomad | <1.11.0-rc.1.0.20260511152149-cd7240c4099a | 1.11.0-rc.1.0.20260511152149-cd7240c4099a |
| GO-2026-5445 | Go | github.com/hashicorp/nomad | <1.11.0-rc.1.0.20260511152149-cd7240c4099a | 1.11.0-rc.1.0.20260511152149-cd7240c4099a |