cve.bz

CVE-2026-71438

2.4 lowEPSS 0.4%

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.

CVSS 4.0
2.4CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:L/VA:L/SC:H/SI:H/SA:H
EPSS
0.4% chance of exploitation in the next 30 days; higher than 28% of CVEs (scores of 2026-10-25)
CWE
CWE-1321
Published
Modified
Record from
the NVD, synced

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c4c3-pg64-4m4vnpmmermaid>=11.0.0-alpha.1 <11.16.111.16.1
GHSA-c4c3-pg64-4m4vnpmmermaid<10.9.810.9.8

References

Check your stackJSON