cve.bz

CVE-2026-69152

7.5 highEPSS 0.6%

The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.

CVSS 3.1
7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 50% of CVEs (scores of 2026-10-25)
CWEs
CWE-400, CWE-770
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-rgw5-rvv9-x895npmbrace-expansion<1.1.181.1.18
GHSA-rgw5-rvv9-x895npmbrace-expansion>=2.0.0 <2.1.42.1.4
GHSA-rgw5-rvv9-x895npmbrace-expansion>=3.0.0 <3.0.63.0.6
GHSA-rgw5-rvv9-x895npmbrace-expansion>=4.0.0 <5.0.95.0.9

References

Check your stackJSON