CVE-2026-66053
Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue. This replaces CVE-2026-41603
- CVSS 3.1
- 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N - EPSS
- 0.3% chance of exploitation in the next 30 days; higher than 21% of CVEs (scores of 2026-10-25)
- CWE
- CWE-297
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:thrift
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-hwrj-9rr4-24xh | PyPI | thrift | <0.24.0 | 0.24.0 |
| PYSEC-2026-3927 | PyPI | thrift | <0.24.0 | 0.24.0 |