cve.bz

CVE-2026-65637

9.8 criticalEPSS 0.8%

Critical (9.8) in apache tomcat. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in org.apache.tomcat:tomcat-coyote 10.1.59, 11.0.25, 9.0.121.

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 54% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat:tomcat-coyote>=11.0.20 <11.0.2511.0.25
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat:tomcat-coyote>=10.1.53 <10.1.5910.1.59
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat:tomcat-coyote>=9.0.115 <9.0.1219.0.121
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat.embed:tomcat-embed-core>=11.0.20 <11.0.2511.0.25
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat.embed:tomcat-embed-core>=10.1.53 <10.1.5910.1.59
GHSA-f525-44xv-f2qjMavenorg.apache.tomcat.embed:tomcat-embed-core>=9.0.115 <9.0.1219.0.121

References

Check your stackJSON