CVE-2026-65591
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
- CVSS 4.0
- 8.9
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L - CVSS 3.1
- 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - EPSS
- 0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-25)
- CWE
- CWE-917
- Published
- Modified
- Record from
- the NVD, synced
Affected
- n8n:n8n
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-pm35-fqvh-cq5g | npm | n8n | <1.123.64 | 1.123.64 |
| GHSA-pm35-fqvh-cq5g | npm | n8n | >=2.30.0 <2.30.1 | 2.30.1 |
| GHSA-pm35-fqvh-cq5g | npm | n8n | >=2.0.0-rc.0 <2.29.8 | 2.29.8 |