CVE-2026-6550
Cryptographic algorithm downgrade in the caching layer of Amazon AWS Encryption SDK for Python before version 3.3.1 and before version 4.0.5 might allow an authenticated local threat actor to bypass key commitment policy enforcement via a shared key cache, resulting in ciphertext that can be decrypted to multiple different plaintexts. To remediate this issue, users should upgrade to version 3.3.1, 4.0.5 or above.
- CVSS 4.0
- 5.7
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 4.7
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N - EPSS
- 0.10% chance of exploitation in the next 30 days; higher than 0% of CVEs (scores of 2026-10-26)
- CWE
- CWE-757
- Published
- Modified
- Record from
- the NVD, synced
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-v638-38fc-rhfv | PyPI | aws-encryption-sdk | >=2.0.0 <3.3.1 | 3.3.1 |
| GHSA-v638-38fc-rhfv | PyPI | aws-encryption-sdk | >=4.0.0 <4.0.5 | 4.0.5 |
| PYSEC-2026-2387 | PyPI | aws-encryption-sdk | >=2.0.0 <3.3.1 >=4.0.0 <4.0.5 | 3.3.1, 4.0.5 |