cve.bz

CVE-2026-63763

7.5 highEPSS 0.5%

High (7.5) in surrealdb surrealdb. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in surrealdb 2.5.0, 3.0.0-beta.3.

SurrealDB before 2.5.0 and before 3.0.0-beta.3 contains a confused deputy privilege escalation vulnerability. Unprivileged users (e.g., those with the database editor role) can create or modify fields containing futures, functions, or closures. Because these are executed in the context of the invoking/querying user rather than their creator, an attacker can plant malicious logic that executes with a higher-privileged user's permissions when that user reads or writes the affected record. This can lead to full privilege escalation, including creation of a root owner and server takeover.

Severity

CVSS 4.0

7.5 high
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 42% of CVEs (scores of 2026-10-31)
CWE
CWE-639
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3v2x-9xcv-2v2vcrates.iosurrealdb<2.5.02.5.0
GHSA-3v2x-9xcv-2v2vcrates.iosurrealdb>=3.0.0-alpha.1 <3.0.0-beta.33.0.0-beta.3

References

Check your stackJSON