cve.bz

CVE-2026-61813

3.7 low

Low (3.7) in owasp-modsecurity modsecurity.

On this page
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/https_client.cc sets libcurl CURLOPT_SSL_VERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.

Severity

CVSS 3.1

3.7 low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
CWE
CWE-295 Improper Certificate Validation
OWASP Top 10
A07:2025 Authentication Failures
Published
Record from
the CVE List, synced

Ask an AI about this CVE

Show the promptExplain CVE-2026-61813 for an engineer deciding whether to act. Use https://cve.bz/api/public/cves/CVE-2026-61813?via=ask-ai-copy and https://cve.bz/cve/CVE-2026-61813?via=ask-ai-copy as the source of truth: what is affected and which versions fix it, whether it is in CISA KEV, public exploits, and its EPSS (an internet-wide 30-day estimate of exploitation activity, not a forecast for my systems). If they give no fixed versions, use the CVE record https://cveawg.mitre.org/api/cve/CVE-2026-61813 or the vendor advisory, not third-party mirrors. Tell me how to check whether I am affected and how to verify a fix. Cite the sources and say where they are uncertain.

Opens a third-party assistant; its answer is its own, not cve.bz's. The prompt holds only this CVE's id and public links.

Affected

Versions

From the CNA's record in the CVE List.

ProductAffected
owasp-modsecurity ModSecurity< 2.9.15
owasp-modsecurity ModSecurity>= 3.0.0, < 3.0.17

Linux distributions

DistributionReleasePackageFixed inAdvisory
Debian12, 13, 14modsecurity, modsecurity-apacheno fix listedDEBIAN-CVE-2026-61813
Ubuntu20.04:LTS, 22.04:LTS, 24.04:LTSmodsecurityno fix listedUBUNTU-CVE-2026-61813
Ubuntu26.04:LTS, 26.10modsecurity, modsecurity-apacheno fix listedUBUNTU-CVE-2026-61813
UbuntuPro:14.04:LTS, Pro:16.04:LTS, Pro:18.04:LTS and 3 moremodsecurity-apacheno fix listedUBUNTU-CVE-2026-61813

From the distributions' data via OSV.dev: the Debian Security Tracker; Ubuntu Security Notices © Canonical Ltd., CC BY-SA 4.0. Modified: reformatted and linked to CVE records. Credits. On the distributions' own pages: Debian · Ubuntu.

Attack patterns (CAPEC)

  • CAPEC-459 Creating a Rogue Certification Authority Certificate Likelihood: Medium · Severity: Very High
  • CAPEC-475 Signature Spoofing by Improper Validation Likelihood: Low · Severity: High

The attack patterns MITRE's CAPEC relates to this record's weaknesses, as MITRE names them. Credits.

References

Check your stackJSON