cve.bz

CVE-2026-59948

7.0 highEPSS 0.1%

High (7.0). EPSS 0.1% chance of exploitation in the next 30 days.

Composer is a dependency Manager for the PHP language. Prior to 2.2.29 and 2.10.2, a maliciously crafted package from an untrusted repository other than Packagist.org or Private Packagist can cause Composer to write attacker-controlled files outside the vendor directory and outside the project during install or update by using an invalid package name that is not correctly validated before dependency-resolution results are written or installed. This issue is fixed in versions 2.2.29 and 2.10.2.

Severity

CVSS 3.1

7.0 high
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
0.1% chance of exploitation in the next 30 days; higher than 3% of CVEs (scores of 2026-10-31)
CWEs
CWE-22, CWE-787
Published
Modified
Record from
the NVD, synced

References

Check your stackJSON