CVE-2026-56356
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
- CVSS 4.0
- 5.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N - CVSS 3.1
- 5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - EPSS
- 0.2% chance of exploitation in the next 30 days; higher than 16% of CVEs (scores of 2026-10-29)
- CWE
- CWE-79
- Published
- Modified
- Record from
- the NVD, synced
Affected
- n8n:n8n
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-3c7f-5hgj-h279 | npm | n8n | <1.123.27 | 1.123.27 |
| GHSA-3c7f-5hgj-h279 | npm | n8n | >=2.14.0 <2.14.1 | 2.14.1 |
| GHSA-3c7f-5hgj-h279 | npm | n8n | >=2.0.0-rc.0 <2.13.3 | 2.13.3 |