cve.bz

CVE-2026-56317

2.3 lowEPSS 0.3%

Low (2.3) in nuxt nuxt. EPSS 0.3% chance of exploitation in the next 30 days. Fixed in nuxt 3.21.7, 4.4.7.

Nuxt before 4.4.7 (and the 3.x branch before 3.21.7) contains a cross-site scripting vulnerability in the NoScript component that writes slot content to innerHTML without escaping. Attackers can inject malicious scripts through untrusted data in NoScript slots, such as route.query parameters, which execute in the document context when the noscript tag is implicitly closed by script tags.

Severity

CVSS 4.0

2.3 low
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
0.3% chance of exploitation in the next 30 days; higher than 27% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-m3q2-p4fw-w38mnpmnuxt>=4.0.0 <4.4.74.4.7
GHSA-m3q2-p4fw-w38mnpmnuxt<3.21.73.21.7

References

Check your stackJSON