cve.bz

CVE-2026-53488

9.4 criticalEPSS 0.2%

Critical (9.4) in linuxfoundation containerd. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in github.com/containerd/containerd 1.7.33.

containerd is an open-source container runtime. In versions prior to 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10 the CRI plugin propagates labels from an image config (LABEL instruction in Dockerfile) to a container without validation. This may result in executing an arbitrary command on the host, via a plugin that consumes container labels for some operations. This issue has been fixed in versions 1.7.33, 2.3.2, 2.2.5, 2.1.9, and 2.0.10.

Severity

CVSS 4.0

9.4 critical
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

CVSS 3.1

8.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 7% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-xhf5-7wjv-pqxpGogithub.com/containerd/containerd>=1.7.0 <1.7.331.7.33
GHSA-xhf5-7wjv-pqxpGogithub.com/containerd/containerd/v2>=2.0.0 <2.0.102.0.10
GHSA-xhf5-7wjv-pqxpGogithub.com/containerd/containerd/v2>=2.1.0 <2.1.92.1.9
GHSA-xhf5-7wjv-pqxpGogithub.com/containerd/containerd/v2>=2.2.0 <2.2.52.2.5
GHSA-xhf5-7wjv-pqxpGogithub.com/containerd/containerd/v2>=2.3.0 <2.3.22.3.2
GO-2026-5758Gogithub.com/containerd/containerd>=1.7.0 <1.7.331.7.33
GO-2026-5758Gogithub.com/containerd/containerd/v2>=2.0.0 <2.0.10
>=2.1.0 <2.1.9
>=2.2.0 <2.2.5
>=2.3.0 <2.3.2
2.0.10, 2.1.9, 2.2.5, 2.3.2

References

Check your stackJSON