cve.bz

CVE-2026-50633

8.1 highEPSS 0.9%

A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

CVSS 3.1
8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.9% chance of exploitation in the next 30 days; higher than 59% of CVEs (scores of 2026-10-25)
CWEs
CWE-20, CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qp3f-rvj8-46c8Mavenorg.apache.cxf:cxf-integration-jca>=4.2.0 <4.2.24.2.2
GHSA-qp3f-rvj8-46c8Mavenorg.apache.cxf:cxf-integration-jca<4.1.74.1.7

References

Check your stackJSON