cve.bz

CVE-2026-50632

8.1 highEPSS 0.7%

A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

CVSS 3.1
8.1CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 51% of CVEs (scores of 2026-10-25)
CWEs
CWE-20, CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-93g8-qqv3-mrx8Mavenorg.apache.cxf:cxf-rt-transports-jms>=4.2.0 <4.2.24.2.2
GHSA-93g8-qqv3-mrx8Mavenorg.apache.cxf:cxf-rt-transports-jms>=4.1.0 <4.1.74.1.7
GHSA-93g8-qqv3-mrx8Mavenorg.apache.cxf:cxf-rt-transports-jms<3.6.123.6.12

References

Check your stackJSON