cve.bz

CVE-2026-49270

5.9 mediumEPSS 0.4%

Medium (5.9) in apache. EPSS 0.4% chance of exploitation in the next 30 days. Fixed in org.apache.activemq:apache-activemq 5.19.7, 6.2.6.

Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Severity

CVSS 3.1

5.9 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
0.4% chance of exploitation in the next 30 days; higher than 30% of CVEs (scores of 2026-10-31)
CWE
CWE-1230
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:apache-activemq<5.19.75.19.7
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:apache-activemq>=6.0.0 <6.2.66.2.6
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:activemq-broker<5.19.75.19.7
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:activemq-broker>=6.0.0 <6.2.66.2.6
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:activemq-all<5.19.75.19.7
GHSA-hf52-78x8-6w3wMavenorg.apache.activemq:activemq-all>=6.0.0 <6.2.66.2.6

References

Check your stackJSON