CVE-2026-49042
Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.
- CVSS 3.1
- 7.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L - EPSS
- 0.7% chance of exploitation in the next 30 days; higher than 52% of CVEs (scores of 2026-10-25)
- CWE
- CWE-20
- Published
- Modified
- Record from
- the NVD, synced
Affected
- apache:camel
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-langchain4j-tools | >=4.8.0 <4.18.3 | 4.18.3 |
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-langchain4j-tools | >=4.19.0 <4.21.0 | 4.21.0 |
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-langchain4j-agent | >=4.8.0 <4.18.3 | 4.18.3 |
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-langchain4j-agent | >=4.19.0 <4.21.0 | 4.21.0 |
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-spring-ai-tools | >=4.8.0 <4.18.3 | 4.18.3 |
| GHSA-hh8r-75r6-qrg9 | Maven | org.apache.camel:camel-spring-ai-tools | >=4.19.0 <4.21.0 | 4.21.0 |