CVE-2026-48746
vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.
- CVSS 3.1
- 9.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - EPSS
- 1.2% chance of exploitation in the next 30 days; higher than 66% of CVEs (scores of 2026-10-25)
- CWEs
- CWE-444, CWE-501
- Published
- Modified
- Record from
- the NVD, synced
Affected
- vllm:vllm
Packages (OSV)
| Advisory | Ecosystem | Package | Affected | Fixed in |
|---|---|---|---|---|
| GHSA-94f4-hr76-p5j6 | PyPI | vllm | >=0.3.0 <0.22.0 | 0.22.0 |
| PYSEC-2026-226 | PyPI | vllm | >=0.3.0 <0.22.0 | 0.22.0 |